+

Problem creating a video Tutorial

Teachers' Lounge

Grab your coffee and come on in.

Got something to say? Looking for advice or inspiration? Post questions, join discussions, compare notes and share your insights on the latest topics in our Teachers' Lounge.

Search
Problem creating a video Tutorial
John Croteau
For the past few weeks I have been unable to use Youtub urls to create video tutorials. I've been successful in the past but now when I attempt to do this I get this message- The YouTube link you provided appears to be incorrect. Please check it and try again. Does anyone have an answer for why this is happening?
Jun. 10, 2015 at 1:13 pm
Georgina Susan
I found a way around this problem by using the embed html function in sophia and getting the embed code for the youtube clip. It now seems to have added the video to my tutorial properly.
Jun. 10, 2015 at 9:56 pm
John Croteau
Thanks Georgina. That worked for me too. I hope Sophia can fix it before I forget how to do this next Fall.
Jun. 11, 2015 at 11:17 am

Sophia loves teachers

From the latest news to the best new tech, we're here to support you every step of the way.

Use Our Standards-Aligned Tutorials and Pathways

Did you know Sophia has tons of great content that aligns with the CCSS and NGSS standards? Get a jump on incorporating them into your everyday teaching.

For Your Classroom

Launch your 21st century classroom with the latest cool tools and apps.

Sophia for Teachers Flipping the Classroom

For You

Learning never stops. Always bring your A-game with the latest professional development tools.

Flipped Classroom Certification iPad® Prepared Certification Chrome Classroom Certification Virtual Classroom Certification